Exchange: Migration „Couldn’t switch the mailbox into Sync Source mode“

Bei der Migration eines Postfaches von Exchange 2010 zu Exchange 2016 ist mit vor kurzem die Fehlermeldung „FailedOther“ untergekommen. Gräbt man nun etwas tiefer und schaut sich mit dem Befehl Get-MoveRequestStatistics den genauen Wortlaut der Fehlermeldung an, erhält man folgendes:

Error: Couldn't switch the mailbox into Sync Source mode.
This could be because of one of the following reasons:
Another administrator is currently moving the mailbox.
The mailbox is locked.
The Microsoft Exchange Mailbox Replication service (MRS) doesn't have the correct permissions.
Network errors are preventing MRS from cleanly closing its session with the Mailbox server. If this is the case, MRS may
continue to encounter this error for up to 2 hours - this duration is controlled by the TCP KeepAlive settings on the
Mailbox server.
Wait for the mailbox to be released before attempting to move this mailbox again.

Auch an dieser Stelle sei gesagt, dass meine Lösung nicht immer zum Erfolg verhelfen muss. Es gibt noch etwaige andere Probleme, die mit der genau gleichen Meldung zusammenhängen können. Nichts desto trotz, schauen wir uns das Problem genauer an.

 

Das Debugging

Durchsucht man das WWW erhält man Vorschläge, dass man unter anderem die TCP Einstellungen des Exchange Nodes anpassen sollte. Anderen soll es bereits geholfen haben, am EX2010 den Befehl „New-MailboxRepairRequest“ auf das betroffene Postfach auszuführen. Da ich über 500 Postfächer erfolgreich auf diese Weise im gleichen Setup migrieren konnte, schien es mir etwas merkwürdig, jetzt an den TCP Einstellungen finetuning zu betreiben. Weiters hat die Postfachreparatur bei mir noch nie zum Erfolg verholfen.

Laut einem Microsoft Docs Artikel wird bei einem MoveRequest bei der Source-Mailbox automatisch das Flag „InTransitStatus“ gesetzt. Dadurch kann gewährleistet werden, dass zur selben Zeit kein anderer MoveRequest auf das Postfach zugreifen kann. Das Interessante an dieser Stelle ist allerdings, dass dieser Flag nur im RAM gespeichert wird. Das bedeutet, dass sobald der Exchange Node neu gestartet wird, sollte das Flag auch verschwinden. Da noch tausende andere Postfächer auf diesem Exchange Cluster aktiv waren, war ein Neustart keine Option. Glücklicherweise lag die Mailbox auf einer Database Availabilty Group (DAG) und es reichte aus, die betroffene Datenbank auf den passiven Node „umfallen“ zu lassen. Dazu wird folgender Befehl verwendet:

Move-ActiveMailboxDatabase -Identity <DATENBANK> -ActivateOnServer <PASSIVER SERVER>

Nach dem Failover habe ich den MoveRequest neu angelegt und die Migration konnte ohne weitere Komplikationen fortgesetzt werden.

Das könnte Dich auch interessieren …

Abonnieren
Benachrichtige mich bei
guest
0 Comments
Inline Feedbacks
View all comments
0
Hinterlass' doch deine Meinung zu diesem Artikelx
()
x